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1. Introduction 

1.1 Purpose 

 
WinAccounts is a simple financial accounting software. It supports VAT calculations and the use of multiple 
currencies: CHF, EUR, USD. 
 
Reading this manual and using WinAccounts requires a minimum of knowledge in financial accounting. This 
manual is not intended to teach you financial accounting, but how to use WinAccounts. 
 
 

2. Installation 

2.1 Install 

To install WinAccounts, simply copy the WinAccounts.exe file to a directory on your hard drive. Typically 
C:Program Files/Accounts. WinAccounts does not make any registry entries. 

2.2 Uninstall 

Delete the WinAccounts.exe file. Nothing else do be done. 
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3. Data Handling 

A single file holds all the data that is used for one accounting period and one accounting entity. The file 
name extension is .wac. The file holds the following information: 

3.1 Configuration Data 

This comprises all information that is specified in the Configuration menu and its submenus. Also, the state 
of the Calculate VAT check box as well as the current currency as set in the input line. 

3.2 Accounts Structure 

This comprises all information that is entered into the list of accounts. For every account, it includes account 
number, account name, parent account, level in hierarchy, possible VAT account and VAT percentage, and 
the denomination. A typical accounts structure may look like this: 
 

811
Schlussbilanz

100
Kassa

102
Bank

201
VAT

210
Eigenkapital

212
Gewinnvortrag

800
Erfolgsrechnung

300
Waren

401
Gehälter

470
Verwaltung

600
Warenverkauf

620
Honorare

471
Büromat

473
Telefon

999
Sammelbuchg

998
Mehrwertst.

106
Vorsteuer 1

2

3

4
 

 
The vertical structure specifies the hierarchy levels as used for balancing the accounts. Accounts that do 
have a parent account are arranged in levels. Levels are numbered starting with 1 for the highest level. 
Balancing starts at the bottom level, i.e. the highest numbered level, and proceeds up to the top until the 
main balance sheet is reached. The balance sheet has not parent account, so the balancing stops there. 
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Note that two accounts are outside that structure. Their only purpose is to make VAT calculations and 
multiple payments more transparent. If everything is OK, those accounts will be empty at the time of 
balance. If not so, there is some error somewhere in the records. 
 
The list of accounts is accessed via the View -> List of Accounts menu item. 

3.3 Accounts Data 

The contents of the individual accounts are not stored. If an account is accessed for display or printout, then 
its contents are reconstructed by scanning the journal for all records that do involve the account of interest. 
This helps in ensuring data integrity, since no same data will be stored twice in different places. 
 

3.4 Records 

The journal records are the core of everything. Accounts themselves do not hold any record information. If 
an account's content are needed for any purpose, they are re-constructed by scanning the journal for all 
records that involve the account of interest. This avoids duplicate data storage and thus ensures data 
integrity. 
 
Every record carries a reference number. You are absolutely free in choosing your numbering system, since 
WinAccounts uses another, invisible reference number for its own purposes. The visible reference numbers 
are just to provide an ordering criterion both for WinAccounts displays and for your connecting a record to 
some piece of paper. Reference numbers are limited to 5 alphanumerical characters. Reference numbers 
may be composed of any decimal digit and any letter character. 
 
Sorting by reference number will behave as follows: 
 
 Records with a lower number of characters in their reference will be sorted first. 
 Letters rank higher than digits. 

4. Currencies Handling 

Every account has a defined currency denomination, and so does every record. 

4.1 Single Currency 

As long as all accounts and records use a single currency (the one that was set as the reference currency 
with a conversion factor of 1.0000 in the configuration), things are very simple. No need for any worry about 
currencies. 

4.2 Multiple Currencies 

When multiple currencies are used, things are a little different: 

4.2.1 Records and Accounts Display 

Records in the journal are always shown with the amount in the record's currency. 
 
When a record is denominated in currency A and an account is denominated in currency B, and the account 
is displayed or used for print, then the record's amount will be shown in currency B, using the conversion 
factor as configured. 

4.2.2 Moving Assets between Denominations 

When moving assets between denominations, e.g. from a EUR bank account into a CHF bank account, it is 
helpful to go via an intermediate account: 
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Let use assume that the EUR bank account number is 1021, and the CHF bank account number is 1020, 
and the intermediate account number is 4221: 
 
15.3.12 00000 EUR debit 4221 1021 400.00 EUR 
15.3.12 00001 CHF credit 1020 4221 482.05 CHF 
 
For the amounts, enter the exact numbers as indicated by the documents from your bank, denominated as 
shown. A possible difference caused by the exchange rate as used by the bank and the exchange rate as 
configured in WinAccounts will show up as a debit/credit in account 4221. The account 4221 would 
normally be denominated in the reference currency that is also used for the final balance sheet. 

4.2.3 Modifying Conversion Factors 

When you change the currency conversion factors in between the start of an accounting period and the end 
of the accounting period, then there will be some capital gain or loss, depending on the direction of change 
of the exchange rate for assets and/or liabilities that are not denominated in the reference currency. Make 
sure that you prepare records for recording these gains or losses. 
 
Let us look at the following example: 
 

 
 
At the beginning of the accounting period, we do have a CHF/EUR exchange rate of 1.2000, and we do get 
the following records when starting the period: 
 
1. 1.13 00001 Opening Bank  102  810 220.00 CHF 
1. 1.13 00002 Opening Bank CHF 1020  102 100.00 CHF 
1. 1.13 00003 Opening Bank EUR 1021  102 100.00 EUR 
1. 1.13 00004 Opening Capital  810  210 220.00 CHF 
 
When we balance the accounts on Dec. 31.2013 after changing the CHF/EUR exchange rate to 1.2500, 
we do get: 
 
31.12.13 zz001 Bank CHF  102 1021 100.00 CHF 
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31.12.13 zz002 Bank EUR  102 1021 100.00 EUR  
31.12.13 zz003 Bank  811  102 225.00 CHF  
31.12.13 zz004 Capital  210  811 220.00 CHF  
 
Now, this is clearly no good: the balance sheet assets and liabilities sums are not equal! To understand 
what happened, have a look at the account # 102: 
 
Date Ref. Text   Credit Debit 
 
1. 1.13 00001 Opening Bank  810 220.00   CHF 
1. 1.13 00002 Opening Bank CHF 1020  100.00 CHF 
1. 1.13 00003 Opening Bank EUR 1021  125.00 CHF 
31.12.13 zz001 Bank CHF  102 100.00  CHF 
31.12.13 zz002 Bank EUR  102 125.00  CHF  
31.12.13 zz003 Bank  811  225.00 CHF  
 
Debit/Credit sums 425.00 450.00 
 
So the bank assets have changed from 220.00 to 225.00, but the liabilities have not changed! 
 
This must be fixed by an extraordinary income record, e.g. 
 
31.12.13 00999 Exchange rate gain  102  720   5.00 CHF 
 
Now, the account # 102 will be balanced again, and the liabilities sum of the balance sheet will increase by 
5.00 since we do have an income. The balance sheet now becomes 
 
Date Ref. Text   Credit Debit 
 
31.12.13 zz004 Bank  102 225.00  CHF 
31.12.13 zz005 Capital  210  220.00 CHF  
31.12.13 zz006 Profit  212    5.00 CHF  
 
Debit/Credit sums 225.00 225.00 
 
This makes the balance sheet to balance properly again. 
 

5. VAT Handling 

In the list of accounts, you can specify if VAT is to be applied to the records for that specific account, and 
you can also define the VAT percentage to be applied. So, when designing your list of accounts, it does 
make sense to group income and expense accounts in accordance with the VAT percentages to be applied. 
 
If you need to record an expense that does not include VAT (i.e. the expense is not entitled to VAT 
deduction) but should be debited to an account that is subject to VAT, then you can disable VAT calculation 
for that one record by unchecking Calculate VAT before clicking Enter. Do not forget to re-check Calculate 
VAT after the entry has been transferred to the journal. 

5.1 VAT on Expenses 

When you record an expense to an account that is subject to VAT, your entry on the input line results in 
three records in the journal, e.g. 
 
31.12.13 00008 telephone bill  473  100 108.00 CHF 
 
will be expanded into 
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31.12.13 00008 telephone bill  998  100 108.00 CHF  
31.12.13 00008 telephone bill  473  998 100.00 CHF  
31.12.13 00008 telephone bill  106  998   8.00 CHF  
 
So the gross amount of the expense is split between accounts # 473 (the actual cost to you) and # 106 (the 
amount that you may claim from the tax authority). The balance on the intermediate VAT account # 998 
should always be 0.00. 

5.2 VAT on Income 

When you record an income to an account that is subject to VAT, then your entry on the input line results in 
three records in the journal, e.g. 
 
31.12.13 00008 invoice 1020  620 108.00 CHF 
 
will be expanded into 
 
31.12.13 00008 invoice 1020  998 108.00 CHF  
31.12.13 00008 invoice  998  620 100.00 CHF  
31.12.13 00008 invoice  998  201   8.00 CHF  
 
So the gross amount of the income is split between accounts # 620 (the actual income to you) and # 201 
(the amount that you owe to the tax authority). The balance on the intermediate VAT account # 998 should 
always be 0.00. 

6. Print Output 

There are no facilities for fancy decorations in print output. Print output will be in a single fixed pitch font. 
 
If you do need fancy output for the income statement or for the balance sheet, you are invited to use your 
standard word processor. This will most probably be needed at most once per year. 
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7. Program Use 

 

 
 
 
The program window is divided into several areas: 
 
Records Window 
The records window shows about 20 records at the time. It can be scrolled arbitrarily. Below the records 
window, there is a 
 
Input Line 
with fields for Date, Reference, Text, Debit and Credit accounts, the Amount and the Currency. 
 
A check box at the lower left is for disabling VAT calculation for a particular record entry even when VAT is 
generally enabled by the respective entries in the list of accounts. 
 
Two fields below the debit and credit account numbers will show the current balance of the respective 
accounts. 
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The Delete button will delete a selected record from the records window. 
 
The Enter button will transfer the contents of the input line to the list of records. 
 
The Close button is for exiting WinAccounts. 
 

7.1 The File Menu 

The File menu provides the standard options: 
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7.1.1 File New 

This opens a dialog for initializing a new accounting entity. There are two options: 
No will close the dialog again and start a blank accounting. 
Yes will use all the information that was gathered in the dialog for taking over the data from another (usually 
last year's accounting for the same entity) accounting: 
 

 
 
WinAccounts needs some information for proper takeover: 
 
The file to be used as a data source must be specified. This must be a .wac file that contains a balanced 
accounting.  
 
Three check boxes are for defining the items to be taken over from the file. 
 
In order to properly open a new accounting period, the opening balance date is needed. 
 
The closing balance account number tells WinAccounts what account from the other file to interpret as a 
closing balance (the balance sheet). 
 
The opening balance account number will be used for opening the new accounting. 
 
Assets and liabilities can be expanded automatically down to the lowest level of accounts when opening the 
new accounting. But in order to identify the respective accounts, WinAccounts needs to know about asset 
and liability account numbers. 
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7.1.2 File Open 

File Open is the standard command for opening an existing file. 

7.1.3 File Save 

This will save to the current file. 

7.1.4 File Save As 

This allows for the specification of a new file name for the data to be saved. 

7.1.5 File Print 

Provides 3 sub-commands: 

7.1.5.1 File Print List of Accounts 

Will print the list of accounts with all account configuration data. 

7.1.5.2 File Print Journal 

Will print the entire journal. 

7.1.5.3 File Print Accounts 

Opens a new dialog where you can specify the range of accounts to be printed by numbers: 
 

 
 
For printing a single account, insert the same number into the From and To boxes. 
 

7.1.6 File Print Setup 

Provides the standard Windows printer setup dialog. 
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7.2 The Tools Menu 

 

 
 

7.2.1 Tools Balance 

This triggers the balancing of the entire accounting. Accounts will be balanced according to the hierarchy as 
specified in the list of accounts. The highest level accounts will be balanced first, and the balance will be 
debited/credited to the parent account at the next lower level. Then the next lower level accounts will be 
balanced and so on until the lowest level (1) has been done, where balances are debited/credited to the final 
balance sheet which has no parent account. 
 
Balancing accounts takes fractions of a second and can be undone again at any time. So you may do it 
once in a while during the accounting period just to make sure that no error has crept into your record 
keeping. 
 
Records resulting from this balancing action will have references that start with zz, so they will be sorted 
into the end of the records list (as long as sorting by reference has been selected in the configuration). 
 
The balance of the final balance sheet may not be exactly 0.00 if you are working with multiple currencies 
due to some rounding. In that particular case, create a separate account for fixing up the balance sheet, e.g. 
997. That account must not be part of the balancing hierarchy, i.e. it must not have a parent account. You 
can then fix up the balance sheet by means of a record such as 
 
31.12.13 00500 balance sheet fixup  991  811   0.01 CHF  
 
Note that in order to fix the balance sheet up, you must first undo a possible balancing, then enter the fixup 
record, and then re-balance everything. 
 
As long as the records have been balanced, some other operations like modifications of the currency ratios 
will be prohibited. 

7.2.2 Tools Undo Balance 

The balancing can be undone at any time by this command. 

7.2.3 Tools Search 

You may search using three different criteria: 
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7.2.3.1 Tools Search Reference 

 
 
will search for records with the given reference. 

7.2.3.2 Tools Search Text 

 
 
will search for records with the given text. 

7.2.3.3 Tools Search Amount 

 
 
will search for records with the given amount. 

7.2.4 Tools Locking 

Locked records cannot be modified any more. 
 
Individual records can be locked / unlocked by right clicking on them in the records window and then 
selecting from the floating menu. 
 
There are two menu options for locking records: 
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7.2.4.1 Tools Locking By Reference 

 
 
will lock the range of records given by From/To. 

7.2.4.2 Tools Locking By Date 

 
 
will lock the range of records given by From/To. 

7.3 The Configuration Menu 

There are four configuration items: 
 

 

7.3.1 Currencies 

In the currencies dialog, you can specify a reference currency (this would be the one that you use for most 
accounts and in particular for the income statement and for the balance sheets). The conversion rate to the 
other two currencies is also specified here. 
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If you use a single currency only, just set the reference. The conversion factor for the reference currency is 
always set to be 1.0000. 

7.3.2 Presentation 

The presentation dialog lets you specify some items that are important to the display or printout of 
information: 
 

 

7.3.3 Users 

The users dialog lets you specify multiple users and their privileges. 
 
If you do not specify any users, the accounting will be open to everybody, and everybody may change any 
entries. 
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There are two user levels: Super and Regular. Super users can do everything, e.g. add/remove other users. 
If you do specify users, you must specify at least one Super user. If you do specify users, every record will 
hold information about which user created it. 
 
If you do check the Use Password box, then you will have to enter passwords for every user. 
 

 

7.3.4 Automation 

In the automation dialog, you can specify an intermediate account for VAT calculation. This account must 
always balance to 0.00 if everything was done correctly. You must also specify an account with the same 
number in the list of accounts, and the account must not have a parent account. 
 
Rounding can be specified for either 5 hundredths of 1 hundredth of the currency units. 
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7.4 The View Menu 

The View menu gives access to the list of accounts and to individual accounts. 
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7.4.1 List of Accounts 

This menu item opens a dialog with the list of accounts: 
 

 
 
In this dialog, you may 
 
 add more accounts 
 edit existing account properties 
 remove accounts (if and only if not referenced by another account or by an existing record) 
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7.4.2 Account 

 

 
 
Here you can select the display of an individual account, either by double clicking it or by selecting it and 
then clicking OK. 

7.5 Help 

Help is currently not implemented. 

7.6 The Floating Menu 

A right click on an entry in the records window opens a floating menu: 
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7.6.1 Edit 

Selecting Edit copies the selected record to the input line for modification. The same can be achieved by just 
double clicking a record. When a record has been modified, clicking Enter will cause the following dialog to 
appear: 
 

 
 
And so you get a chance to discard the modification. 
 
Note that records that have been locked can not be edited any more. 

7.6.2 Author 

Selecting Author will show the date and time of last modification and the author of the last modification to the 
selected record: 
 

 

7.6.3 Lock 

Selecting Lock will require you to confirm your intention: 
 

 

7.6.4 Delete 

Selecting Delete deletes the selected record. To delete a record, you may also select it and then hit the 
Delete key on your keyboard. 
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8. Transitions 

For a compact example for the handling of transitions, we start from the following structure of assets and 
liabilities: 
 

102
Bank

210
Capital

205
Payables

211
Accumulated

Surplus

212
Declared
Reserves

1020
Bank CHF

1021
Bank EUR

100
Cash

105
Receivables

Assets Liabilities

810
Opening Bal

 
 

8.1 New Accounting 

When a new accounting is started, and there is no closing balance sheet from a previous accounting period, 
then the journal entries must be edited manually and will be the following: 
 
Date Text Credit Debit Amount 
 
1.1.2013 Opening Cash 100 810 100.00 CHF 
1.1.2013 Opening Bank 102 810 500.00  CHF 
1.1.2013 Opening CHF 1020 102 200.00  CHF 
1.1.2013 Opening EUR 1021 102 260.00  EUR 
1.1.2013 Opening Receivables 105 810 600.00 CHF 
 
1.1.2013 Opening Payables 810 205 100.00 CHF 
1.1.2013 Opening Capital 810 205 800.00 CHF 
1.1.2013 Opening Accumulated Surplus 810 211 200.00 CHF 
1.1.2013 Opening Declared Reserves 810 212 100.00 CHF 
 
Note that the opening of the EUR account must be declared in EUR, and that the sum of the EUR account 
contents in CHF as calculated by the configured exchange rate and the CHF account must be equal to the 
contents of the total bank account. 
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8.2 Takeover from Last Accounting Period 

When taking over from a preceding accounting period, we have a slightly different situation: the opening 
balance sheet of the new accounting period is the same as the closing balance sheet of the preceding 
period. Also, the contents of all assets and liabilities accounts down to the lowest level in hierarchy must 
match the contents of the same accounts at the time of closing the preceding period. This may involve quite 
some manual work. To avoid this, WinAccounts can take care of the takeover for you: 
 
After closing the preceding accounting period, save the file. 
 
From the menu, select File->New. The takeover dialog will be opened: 

 
 
Now browse to the file from the preceding 
accounting period. 
 
Set the check boxes for the items that you 
want to take over from the preceding 
accounting period. 
 
If you want to take over the balance, then 
specify the opening balance date, the 
account number for the closing balance 
sheet of the preceding accounting period, 
and the account number for the opening 
balance sheet of the new accounting period. 
 
If you want WinAccounts to resolve the 
opening balance sheet down to the lowest 
level of hierarchy of the assets and liabilities 
accounts, then you must also tell 
WinAccounts about the first digit of the 
assets and liability account numbers. 
 
Finally click YES. WinAccounts will now 
create an opening balance sheet from the 
closing balance sheet, and also resolve all 
assets and liabilities down to the lowest level 
in hierarchy. Currency conversions will be 
taken care of by WinAccounts. If you took 
over the configuration from the preceding 
period, the amounts in the other currencies 

in the opening balance will match the amounts of the same currency in the closing balance exactly, and you 
do not need to deal with any currency conversions yourself. 
 
Finally, you now need to save the newly opened accounting to a file of its own. For that purpose, select 
File->Save As... from the menu and specify a file name for the newly opened accounting. 
  


